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L5 Jarrior™ Development Studio

for Freescale™ S12(X) Microcontrollers Quick
Start

SYSTEM REQUIREMENTS

Hardware PC with 1 GHz Intel® Pentium®-compatible
processor
512 MB of RAM (1 GB recommended)
CD-ROM drive
Depending on host-target connection: Parallel
Port, 9-pin Serial Port, or USB Port

Operating System Microsoft® Windows® 2000,
Microsoft Windows XP, or
Microsoft Windows Vista™ Operating Systems 32
bit (Home Premium Edition and Business Edition)

Disk Space 2 GB total
400MB on Windows system disk

This Quick Start explains how to install the CodeWarrior Development
Studio for S12(X) V5.0 software and then create, build, and debug a
project using the IDE.

NOTE In this document, numbered steps are for advanced users.
Lettered steps are the expanded descriptions.

Section A: Installing Software

1. Install the CodeWarrior software.

a. Insert the CodeWarrior Development Studio installation CD into the
CD-ROM drive — Auto Install begins.

NOTE If Auto Install does not start, run Setup. exe, located in the
root directory of the CD.



|
y

'
A

e~

® oo o

-

...e CodeWarrior software may be part of a DVD included with
your kit. In this case, click Install CodeWarrior Development
Studio for S12(X) V5.0, follow the on-screen instructions, and
skip to step "Check for updates".

Click Launch the installer — the Install wizard appears.
Click Next — the License Agreement page appears.
Select the | accept the terms in the license agreement option button.

Continue clicking Next to step through wizard pages, accepting default
settings — the Ready to Install the Program page appears.

Click Install — At the end of installation, a page appears announcing
installation is complete.

Select the Yes, check for program updates (Recommended) after
setup complete checkbox to check for updates.

2. Check for updates.

NOTE

NOTE

If the updater already has internet connection settings, you
may proceed directly to sub-step f.

Click Settings in the CodeWarrior Updater dialog box — the
CodeWarrior Updater Settings dialog box appears.

Click Settings — the Connections page of Internet Properties dialog
box appears.

Modify settings, as appropriate, to successfully connect to internet.
Click OK — the Internet Properties dialog box closes.

Select an item in the Update Check Scheduling list box and click OK; or
click Cancel.

Click Next.
If necessary, enter the username and password.

If updates are available, follow the on-screen instructions to download the
updates to your computer.

If no updates are found, the software application will display an
appropriate message.

Click Finish — the installation completes and the CodeWarrior Updater
dialog box closes.
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..~ .~ . urlicensing and activation of your CodeWarrior Development
Studio for Freescale S12(X) Microcontrollers, refer to the
CodeWarrior Development Suite Quick Start. Save the license
file, 1icense.dat to the installation root folder, the default is
C:\Program Files\Freescale\CodeWarrior for
S12(X) V5.0.

Section B: Creating and Building an S12(X) Project

1. Create a new project.

a. Select Start > Programs > Freescale CodeWarrior > CodeWarrior
Development Studio for S12(X) V5.0 > CodeWarrior IDE — the IDE
starts and the Startup dialog box appears.

Startup Dialog Box
Startup. 5_7\

E Create New Project

Load Example Frojeat
Load Previous Projest
Eiun Gelting Started Tutorial
Start Using CodeWarrior

¥ Display on Startup

b. Click Create New Project — the Device and Connection page appears.

NOTE This section of the quick start demonstrates using the New
Project Wizard. We use an MC68HC912DG 128 target as an
example.

c. Expand HC12 and Automotive Family and select the
MC68HC912DG128 derivative.



Device and Connection Page

HC(5)12(X) Microcontrollers New Project

Wizard Map

Device and C

Select the derivative you would like to use

Choose your default connection

Project Parameters

Add Addttional Files

=-HC12 ) Connections
=1 Automative Family
MC8HCB 1244 P&E Multiink/Cydone Pro
MCB8HCI12B32 Abatron BOI
MCBBHCI12D60
MCB8HCS12D60A
MC68HCI12DG 128
MC68HC912DG 128A
MC68HC12DT 128
MCE8HCS 12DT 1284 Freescale Ful Chip Simuiation wih
+ HCS12 —' |simulation of an-chip peripherals. Later on in
5 HOS 12X he debugger you can swilch to hardware
+- HCS 12XA Family [ebugging
- HCS 1248 Family
- HCS 124D Family 3

Ned » | cancel

d. Select Full Chip Simulation as your default connection.
e. Click Next — the Project Parameters page appears.

Project Parameters Page

HC(S)12(X) Microcontrollers New Project

C/C++ Opticns
PC-Lint

Wizard Map

Device and Connection

Project Parameters
Add Additional Files

Please chaose the set of languages to be
supported initially. You can make mufiple
selections

5
I Relocatable assembly.
¥ c

I c

FThis will set up your application wih an
JANSIC compliant startup code (doing
Iniiaization of global variables).

Project name

[Project mep
Location
[D:\Profiles"b14174\My Documents\Project’

Set...

MNext > Einish | Cancsl |

f. In the Project name text box, type a project name of your choice.

NOTE The IDE automatically creates a folder with the same name in
specified location. The IDE automatically adds .mcp extension

when it creates project.

g. Inthe Location text box enter location to store the project.
h. Select the C checkbox as language to be supported by the project.
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. U can select Finish to accept defaults for remaining options.

i. Click Next — the Add Additional Files page appears.

This page allows you to browse folders and add or remove files to or from
the project.

Add Additional Files Page

HC(S)}12(X} Microcontrollers New Project ]

Wizard Map

Device and Connection
Project Parameters
Add Additional Files
C/C++ Options

PC-Lint

Add existing fies to the project

-3 Program Files a8

#-{2) AccessManager
HI-{) activerDF b | 4
B3 Adabe
- Altiris emove |
B3 Apoint
B2 Apple Software Update
B Audacity
i) Blueberry Software
B+ BlueTooth
-3 C2C Systems
] »

Project Flles

[V Copy files to project

[¥ Creats main.c/main asm file

o copy the added files to the project falder, select "Copy Fies

Selectfiles to be added to the new project and press "Add.."
‘o have the wizard generate default main G and/ar main asm i

< Back Next >

to Project”
o=, select "Create

X (e

Enish Cancel

j-  Click Next — the C/C++ Options page appears.

C/C++ Options Page

HC(S)}12(X) Microcontrollers New Project

Wizard Map
VWhich level of startup code do you want o use?
Select minimal startup code'for best code densiy.

[This will perform an ANS] compliart
ktartup code: t inializes global

Device and Connection
Froject Parameters
Add Addiional Fles
C/C++ Options
PC-Lint

" minimal startup code
@ ANSTstartop code)

Vihich memory modl shal be ussd?
 Smal

 Barked

" Lage

Selsct the floating point format supportsd
Select ‘None'for best cod densiy.

i* None

" float is IEEE32, double is IEEE32

" float is IEEE32, double is IEEE64.

< Back

anables/objects and calls the
izpplication main routine

Carcel |

k. Select the ANSI startup code option button as level of startup code to

use.

I.  Select the Small as memory model option button as memory model to

use.



x 't the None option button for floating point format to support.
n. Click Next — the PC-Lint page appears.

PC-Lint Page

HC(S)}12(X) Microcontrollers New Project ‘Z|
‘Wizard
e Do you want 1o create = project sst up
for PCArt (TH)7

Device and Connection
Project Parameters € Yes
2 Addiioral Fles & e
C/C= Options
PC-Lint

[t tools can find common programming mistakes or
uspicious lines in source code by analyzing it.
PCAnt(TH) is & procuct from Gimpel Software. You
eed the PCInt(TM) software from Gimpel installed in
rderto use the CodeWarior plugin
‘ou can enable PCAnt(TM) later by manually cloning
target and changing the linker to PCAint linker.

< Back Hew> | Frish | Cancal

o. Select the No option button.

p. Click Finish — the IDE creates a project according to your specifications;
the Project window appears, docked at left side of main window.

NOTE To undock project window, double-click the double gray lines.
To re-dock window, right click in title tab and select Docked.

Project Window

Freescale Codi

File Edt View Search Project ssor Expert  Window
AEsEacx<haA AN EER s EER
=]

[ Fut Crp Simuiation Ry &5

Fies | Link Order | Targets |

¥ | Fie | Code | Dats @ -
« E-6350uces i 0. -
¢ @ mainc 0 0.
L3 -0l datapage.c 0 0e =
# {0 Includes 0 0 =
w [+ Project Settings 0 0e =
w #-{]Libs 0 0e =

s la

10 fles: 0 0
gl I |

[Be
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\ connection.
ror tnis example, we specified Full Chip Simulation (FCS).

a. To change the derivative and connection, click the Change MCU/
Connection i icon.

b. Select Full Chip Simulation from the drop-down list.

Edit the source code

a. Double click main.c in the Sources folder — the Editor window opens
displaying contents of file.

main.c in Editor Window

9=
b -4} - M- [+ o'~ Path: | D:\Profiles'b 14174\My Documents\Proj ‘mainc <>
#include <hidsf . h> /* common dsfines and macrc * D

#include "derivative.h® /v derivative-specific ”l)Eu ition

wvoid main(void) {
I+ put your ovn cods hers */

EnableTnterrupts;

/* feads the dog */

c= surs that you never leave main */

LLine 1 Col 1 | [

b. Make changes to the contents of main. c file, if desired.

c. If you make changes to themain.c file, from IDE main menu bar, select

File > Save — IDE saves the changes.

Add files, if required.

In the project window, select a folder.

From the IDE main menu bar, select Project.

Select Add Files — the Select files to add dialog box appears.
Navigate to the directory that contains file you want to add.
Select filename of the file you want to add to the project.

-~ o a0 TP

added to target, if path is new to the project.

g. Inthe project window, filename of the added file appears under the
selected folder.

Click Open — Project messages appear indicating access path has been



x } project.

a. From the IDE main menu bar, select Project.

Select Make — the IDE builds (assembles, compiles, and links) project;
the Error & Warnings window opens showing any error messages and
warning messages.

Section C: Debugging an S12(X) Project

1. Start the debugger.

a. Click on the project window title bar to activate the project window.

b. From the main menu bar, select Project > Debug — the True-Time
Simulator & Real-Time Debugger window appears.

 Data:1

main.c Auto | Symb =3 ) Auto

(£ (*) [ENNEIES

main futo | Symb | Local

I

For Help, press F1 2.000000MHz |42 ImceBhco 1209128 [Breakpoint

N

NOTE The Source and Assembly panes display main.c program
and code.

2. Set breakpoints.

a. Point at a C statement in the Source window and right-click — Source
context menu appears.

b. Select Set Breakpoint — Permanent breakpoint mark is set.
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project.

a. From the main menu of the True-Time Simulator & Real-Time
Debugger window, select Run — Run menu appears.

b. Select Start/Continue or click on Start/Continue icon =+ — the
program executes till the first breakpoint and the Command pane
displays the program status.

Command Pane

T Command (9i=13]
=

Postload command file correctly executed. _
main 0x8000 T

STARTED

RUNNING

Breakpoint -

4. Click the Start/Continue icon =+ — the simulator resumes execution.

5. Click the Halt icon |i| — the simulator stops program execution.

6. From the Debugger Simulator window toolbar, select File > Exit to
exit the debugger.

7. From the IDE main window toolbar, select File > Exit to exit the
CodeWarrior IDE.

Section D: Creating and Building an S12(X) Project with

XGATE Support

1. Create a new project.

a. Select Start > Programs > Freescale CodeWarrior > CodeWarrior
Development Studio for S12(X) V5.0 > CodeWarrior IDE — the IDE
starts and the Startup dialog box appears.
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Startup.

Startup Dialog Box

E Create New Project

Load Example Frojeat
Load Previous Projest
Eiun Gelting Started Tutorial
Start Using CodeWarrior

¥ Display on Startup

b. Click Create New Project — the Device and Connection page appears.

NOTE This section of the quick start demonstrates using the New
Project Wizard. We use an MC9S12XDP512 target as an

example.

c. Expand HCS12X and HCS12XD Family and select the MC9S12XDP512

derivative.

HC(S)12(X) Microcontrollers New Project

Wizard Map

Select the derivative you would like to use:

Device and Connection Page

Chaose your defaut connection:

Device and C
XGATE Setup

Project Parsmeters
Add Addtional Files

Frocessor Expert

HC12 ]
# HCS12
= HCS 12
¥ HCS 12XA Family
- HCS 12X Family
=1 HCS12%D Famiy
MCSS 14064
MCSS 140128
MCSS 120256
MCS5 120G 128
MCS5 1HDR512
MCI5 124DQ256 4
MCSS 12T 256
MCSS 12¥DT384
MCSS 12XDT512

Connections

P&E Multilink/Cydone Pro
SofTec HCS12

Abatron BDI

TBDML

Freescale Full Chip Simulation with simulation
on-chip peripherais. Later on in the
ebugger you can switch to hardware
debugging

Cancel

d. Click Next — the XGATE Setup page appears.

10




h o
L |

Multi Core (HCS12X and XGATE) option button. XGATE Setup
Page

HC(S)}12(X} Microcontrollers New Project ]

‘Wizard —
— Would youlike to have the support of XGATE?. [ created projact wil coniain soucs
ods for the HCS 12X and the XGATE.

Device and Connection
-

XGATE Setup Single Core (HCS12X)

Projsct Paramters o it Core [HCS 12X and XGATE

Add Additional Fles

XGATE Options

< Back New > \ Cancsl

e. Click Next — the Project Parameters page appears.
Project Parameters Page

HC(S}12(X)} Microcontrollers New Project 3]
Wizard
e e e T [ e T
supperted ntaly. You can make mutiple
Project
Devics and Connection selections [Frectmep
Locaton:
EEEETD r [+ Profles 512174 iy Documerts Projeci
o O ™ Relocatable assembly
St
2dd Addtional Fles o =]
Ce
C/C++ Options

is wil s2t Up your application wih a
-+ startup code (doing dlobal class
bject intiaiization).

Memory model options
XGATE Options
PC-Lint

< Back Next > Enish Cancel

NOTE The IDE automatically creates a folder with the same name in
specified location. The IDE automatically adds . mcp extension
when it creates project.

f. In the Location text box enter location to store the project.
g. Select the C checkbox as language to be supported by the project.

11



..~ .~ .U can select Finish button to accept defaults for remaining

options.

h. Click Next — the Add Additional Files page appears.

This page allows you to browse folders and add or remove files to or from
the project.

Add Additional Files Page

HC(S)}12(X} Microcontrollers New Project ]
Wizard Map
Add existing fles to the project
Device and Connection =) Program Files ] Project Files
#)-{7) AccessManager
XGATE Setup #1-£3) activePDF 3
Project Parameters #D) Adobe
-5y Altiris
Add Additional Files - 0) Apoint
C/C+ Options 52 Apple Software Update
- Audacity
Memory model options &) Blueberry Software [V Copy files to project
B+ BlueTooth
KGATE Options #1-(3) C2C Systems [V Create main.c/main asm file
PC-Lint T o

o copy the added files to the project falder, select "Copy Files to Project”

Selectfiles to be added to the new project and press "Add.."
o have the wizard generate default main G and/or main asm fies, sslect "Create

X (e

< Back Next > Enish Cancel

i. Click Next — the C/C++ Options page appears.
C/C++ Options Page

HC(S)}12(X} Microcontrollers New Project ]

Wizard Map -
VWhich level of startup code doyouwantto use?  [This will parform an ANSI complart
Select ‘minimal startup code'for best code density. ktartup code: it initializes global

Device and Connection ariables/objects and calls the
¢ minimal startup cods lapplication main routine.

XGATE Setup = BNl startup code]

ok i Vihich memery madel shallbe used?

Add Additional Files ¢ Small

&
C/C++ Options g i
e s e " Custom

RS Cntiocs Select the floating poit formt supportsd.
e Select None'for best code densty.

i* None

" float is IEEE32, double is IEEE32

" float is IEEE32, double is IEEEE4

< Back New > Erish \ Cancsl \

j.  Select the ANSI startup code option button as level of startup code to
use.

k. Select the Banked option button as memory model to use.

12
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't the None option button for floating point format to support.
Click Next — the Memory model options page appears.
Select FLASH from the Memory Mapping option buttons.

Memory Model Options Page

HC(S)12(X) Microcontrollers New Project

Wizard Map

Device and Connection

Select i all non-censtant data fit in the non-paged RAM or all constants and the code fiinto
the non-paged flas

XGATE Setup

Memory Mapping
Froject Parameters  HAM

@ FLASH
Add Additional Fles  Edemal

C/C++ Options Use both ranges (x4000-B7FFF and BCO00-OcFFFF for placing code and constants?
© Yes

Memory model options & 1o

XGATE Options Use MemoryBanker for:

PC-Lint O

ioose fhis f you are ot sore wil nen-corstart. deta i i fhe non-paged RAM or consiants
nd the cods ft irto the non-paged flash

Cancel

< Back Next >

Erish \

Click Next — the XGATE Options page appears.

Select None from the Select the XGATE Floating point support option
buttons.

g. Select XGATE in RAM from the Select which memory will be used to
store XGATE code option buttons.

XGATE Options Page
HC(S)12(X) Microcontrollers New Project 5]

Wizard
— Select the XGATE Floating point support fThe created project will contain source
ode forthe HCS12X and the XGATE.
& HCS12X code copies the XGATE
ode from flash into ram and then
corfigures|the XGATE.

Device and Connection & None

XGATE Setup (" float is IEEE32, double is IEEE32
Project Parameters
Add Additional Files
Select which memory wil be used ta store XGATE
C/C+=Options =

Memory mods eptions
& XGATEin RAM

" XGATEin FLASH
" XGATEin RAM and FLASH

XGATE Options
PC-Lint

Cancel

<Back Next >

Erish

r.  Click Next — the PC-Lint page appears.

13



x PC-Lint Page

HC(S)12(X) Microcontrollers New Project 3]
‘Wizard
e Do you want to create a project set up
for PCAirt (TM)?
Device and Connection
HGATE Sstup  Yes
& g

Project Parameters
Add Additional Files
C/C+=Options

Memory mods eptions

[lirt tools can find common programming mistakes or
XGATE Options uspicious lines in source code by analyzing it
FCint(TH) is @ product from Gimpel Softrvare. You
PC-Lint e=d the PCIint(T) software from Gimpel installed in
rderto use the CodeWariar plugin
‘ou can enable PCAnt(TH) later by manually dening a
argat and changing the linkerto PCint nker

<Bock | ness | frsh | Cancel |

s. Select No from the Do you want to create a project set up for PC-
lint(TM) option buttons.

t.  Click Finish — the IDE creates a project according to your specifications;
the project window appears, docked at left side of main window.

NOTE To undock project window, double-click the double gray lines.
To re-dock window, right click in title tab and select Docked.

Project Window
Freescale Code! ior
File Edit View Search Project Processor Expert Window Help

AEsEr e xhBA AN mERsERER
=

[Dr rrchosmision <[ R B ¥ B %

Fies | Link Order | Targats |

0 Includes
« (0 Project Settings
@ #-{Libs

¢ | Fie | Code | Data [ -
¥ =2 50uces [ [
¥ A main.c 0 0.
L2 M datapage.c 0 0.
+ A xoate.cugate 0 0.
B woaten 0 i
0 0
0 0
0 0

13 files 0 [t}
I i =T

B

14



.+~ .~ v Uundock Project window, double-click docking handle
(double gray lines at top of window). To re-dock window, right
click in title bar of Project Window, and select Docked.

2. Select a connection.
For this example, we specified Full Chip Simulation (FCS).
a. To change the derivative and connection, click Change MCU/
Connection icon 1k .
b. Select Full Chip Simulation from the drop-down list.

3. Edit the source code.

a. Double click main.c in the Sources folder — the Editor window opens
displaying contents of file.
b. Make changes to the contents of main. c file, if desired

c. If you make changes to the file, from IDE main menu bar, select File >
Save — IDE saves the changes.

main. c in Editor Window

9=}

b -} - M- B~ o - Pah:| D:\Proflesib14174\My Documerts\Project T\Sources\main.c o
Pineluds « =
#includa © —
#include <string.hs
4includa "xgate-h*

data batwasn XOATE and SL2X *.
s are accessing it. *f
\
\ _
INT CFDATA ARK[{(vec_adr) & OxOF) >» 11= (cfdata)
sctor addreses 2 0 chanmal id +/
orTable - XGATE_VECTOR_OFFSET) ;
SATE 4/
* RQET-1 and PRIO=1 */
Line 1 Col1 [14] | »(A

4. Add files, if required.

In the project window, select a folder.

From the IDE main menu bar, select Project.

Select Add Files — the Select files to add dialog box appears.
Navigate to the directory that contains file you want to add.

®© 2 0 T o

Select filename of the file you want to add to project.

15



x Open — Project messages appear indicating access path has been
auucd to target, if path is new to the project.

g. In the project window, filename of the added file appears under the
selected folder.

5. Build the project.

a. From the IDE main menu bar, select Project.

b. Select Make — the IDE builds (assembles, compiles, and links) project;
the Error & Warnings window opens showing any error messages and
warning messages.

Section E: Debugging an S12(X) Project with XGATE

Support

1. Start the debugger.

Click on the project window title bar to activate the project window.
b. From the main menu bar, select Project > Debug — the True-Time
Simulator & Real-Time Debugger window appears.
True-Time Simulator & Real-Time Debugger Window
EEE

DBH %%Eﬂﬂaau .e.-u_l

[-]Ox)
pGATE

Enablelnterrupta;
EO)

B Assembly:1 | & Assembly:2
HC12 'main HGATE

=i Register:1 [=I[=]3] |mlProced.. egis | @lProced... |- J[ox)
HC12 [CPU Cycles: 9726 Auto HC12 XGATE |CPU Cycles: 9726 Aulu XEATE
[ [ [o

nain () R o m[ o = a
R4 0 RS 0 R& 0

 Data: s - JB)E] |5 :
(o2 man fesate [ Wbeae| [

For Help, press F1 HC12 [2.000000MHz 9726 MC9S12¢DP512  [Breakpoint

NOTE The Source and Assembly panes display main.c program
and code. The left set of windows displays the state of

HCS12X core and the right set displays the state of XGATE
core.

16



‘ k ject
a. From the main menu of the True-Time Simulator & Real-Time

Debugger window, select Run — Run menu appears.

b. Select Start/Continue or click on Start/Continue icon — the
program executes till the first breakpoint and the Command pane
displays the program status.

Command Pane

TE Command

Postload command file correctly executed.
main OxFE801C'L T

STARTED

RUNNING

Breakpoint

STARTED

RUNNING

in> ~

3. Click the Start/Continue icon — the simulator resumes execution.

4. Click the Halt icon |- | — the simulator stops program execution.

5. From the Debugger Simulator window toolbar, select File > Exit to
exit the debugger.

6. From the IDE main window toolbar, select File > Exit to exit the
CodeWarrior IDE.

Congratulations!

You have successfully created, built, and debugged an S12(X)
project and an S12(X) project with XGATE Support using the
CodeWarrior Development Studio for S12(X) V5.0 software!

17
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